Command not found: compdef

Nach der Installation von Angular unter macOS erschient im Terminal beim Start folgende Meldung:

/dev/fd/12:18: command not found: compdef

Hintergrund ist das bei der Installation von Angular die Konfigurationsdatei .zshrc der Shell angepasst wurde:

# Load Angular CLI autocompletion.
source <(ng completion script)

Um das Problem zu lösen, kann die betreffende Änderung in der Konfigurationsdatei entfernt werden. Alternativ kann die generelle Autovervollständigung vor dem Laden der Angular-Autovervollständigung aktiviert werden:

# Init command-line completion
autoload -Uz compinit
compinit

Anschließend sollte die entsprechende Meldung nicht mehr auftreten.

SSH-Schlüssel neu generieren

Um Verbindung mittels SSH aufzubauen bzw. solche entgegenzunehmen, wird ein SSH-Schlüssel benötigt. Für den OpenSSH-Server finden sich diese Schlüssel im Verzeichnis /etc/ssh/. Um die Schlüssel für den Server neu zu generieren, müssen die alten Schlüssel gelöscht werden:

rm /etc/ssh/ssh_host_*

Anschließend wird der OpenSSH-Server neu konfiguriert, damit neue Schlüssel erzeugt werden:

dpkg-reconfigure openssh-server

Nachdem dies geschehen ist, muss im letzten Schritt der SSH-Server neu gestartet werden:

systemctl restart ssh

Damit sind die Schlüssel ausgetauscht. Bei einem erneuten Verbindungsversuch, wird ein entsprechender Client deshalb eine entsprechende Warnmeldung ausgeben, welche dann bestätigt werden muss.

Previews unter Nextcloud deaktivieren

Nextcloud erzeugt Vorschaubilder von Dateien, wie z.B. Bildern und Videos. In vielen Fällen ist das ein sinnvolles Feature, allerdings kann es bei Bedarf auch deaktiviert werden. Dazu muss im ersten Schritt die Konfigurationsdatei geöffnet werden:

nano config/config.php

Dort sollte dann folgende Option hinzugefügt werden:

'enable_previews' => false

Nachdem die Konfiguration gespeichert wurde, werden keinerlei Vorschaubilder mehr generiert. Diese werden im Normalfall in einem Ordner innerhalb des data-Verzeichnisses gespeichert. Somit wirkt sich die Einstellung nicht nur auf die Performance, sondern auch auf den Speicherbedarf aus.

WordPress Pseudo-Cronjob-System deaktivieren

WordPress verfügt über ein Pseudo-Cronjob-System, über welches regelmäßige Aufgaben seitens WordPress ausgeführt werden. Hintergrund ist, dass die meisten Webhosting-Pakete über keine echte Cronjob-Funktionalität verfügen. Ausgelöst wird das Pseudo-Cronjob-System durch Besuche der Webseite.

Allerdings führt dies auch zu Problemen; da es so vorkommen kann, das bestimmte Dinge, wie die Veröffentlichung geplanter Artikel, sich verzögern können. Wird WordPress auf einem dedizierten Server ausgeführt, kann hier auf einen echten Cronjob gewechselt werden. Dazu müssen zur Konfigurationsdatei wp-config.php folgende Zeilen hinzugefügt werden:

/* Deaktiviere WordPress Pseudo-Cronjob-System */
define('DISABLE_WP_CRON', true);

Damit die Cronjob-Funktionalität weiterhin funktioniert, muss der Cronjob entsprechend eingetragen werden. Dazu wird die Crontab-Datei im Kontext des Nutzers www-data geöffnet:

sudo -u www-data crontab -e

Dort sollte dann die entsprechende Zeile hinzugefügt werden:

*/1  *    * * *   php /var/www/wordpress/wp-cron.php

Damit werden die Aufgaben, welche WordPress im Rahmen seines Pseudo-Cronjob-System durchführt, nun durch einen echten Cronjob durchgeführt. Damit ist die Zuverlässigkeit des Systems erhöht und geplante Aufgaben, werden immer zeitnah erledigt.

WLAN-Kanäle zu CAPsMAN hinzufügen

Für Netzwerktechnik betreibe ich Geräte von MikroTik. Zur Verwaltung meiner WLAN-Access Points nutze ich die Technik CAPsMAN und wollte für diesen die entsprechenden Kanäle für das 2,4 und 5 Ghz-Band hinzufügen. Der einfachste Weg führt an dieser Stelle über das MikroTik-Terminal:

/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-1 frequency=2412
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-2 frequency=2417
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-3 frequency=2422
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-4 frequency=2427
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-5 frequency=2432
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-6 frequency=2437
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-7 frequency=2442
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-8 frequency=2447
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-9 frequency=2452
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-10 frequency=2457
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-11 frequency=2462
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-12 frequency=2467
/caps-man channel add band=2ghz-b/g/n name=channel-2ghz-13 frequency=2472

Für die Kanäle im 5 Ghz-Band kann analog verfahren werden:

/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-36 frequency=5180
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-40 frequency=5200
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-44 frequency=5220
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-48 frequency=5240
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-52 frequency=5260
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-56 frequency=5280
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-60 frequency=5300
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-64 frequency=5320
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-100 frequency=5500
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-104 frequency=5520
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-108 frequency=5540
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-112 frequency=5560
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-116 frequency=5580
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-120 frequency=5600
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-124 frequency=5620
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-128 frequency=5640
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-132 frequency=5660
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-136 frequency=5680
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-140 frequency=5700
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-149 frequency=5745
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-153 frequency=5765
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-157 frequency=5785
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-161 frequency=5805
/caps-man channel add band=5ghz-a/n/ac name=channel-5ghz-165 frequency=5825

Anschließend sind die Kanäle im CAPsMAN unter dem Tab Channels zu finden und können für die Konfiguration der Access Points genutzt werden. Auf weitere Details und Hintergründe zur richtigen Kanal-Konfiguration geht ein entsprechender Artikel bei SystemZone ein.