seeseekey.net - Invictus Deus Ex Machina

Wie ich in einem Artikel beschrieb funktioniert CardDAV in Verbindung mit den iOS 7 Betas nicht. Mittlerweile gibt es dazu auch einen Bugreport im ownCloud Bugtracker. Wie es scheint, kommt der Fehler dadurch zu Stande das iOS 7 die Anfragezeichenkette dupliziert:

[11/Aug/2013:18:05:48 +0200] "PROPFIND /owncloud/remote.php/carddav/addressbooks/USERNAME/contacts/owncloud/remote.php/carddav/principals/USERNAME/ HTTP/1.1" 401 1163 "-" "iOS/7.0 (11A4449a) dataaccessd/1.0"

Das sieht verdächtig nach einem Fehler in der iOS 7 Beta aus. Es betrifft dabei alle Betas von Beta 1 bis Beta 5. Hier kann man nur hoffen das Apple bis zur fertigen Version noch nachbessert.

7 Kommentare

  1. Ach, deswegen funktionierts nicht. Hatte mir gestern doch mal die Beta draufgespielt und wundere mich nun, dass es nicht funktioniert. Hier wird von einem zusätzlichen Query-String gesprochen, das probier ich später aus.

    Antworten

  2. Selbst GM bringt keine Besserung!

    Antworten

  3. Pingback: ownCloud iOS 7 CardDAV Problem umgehen | seeseekey.net

  4. Genau deswegen bin ich zu iOS6 zurück. Nun habe ich iOS7 wieder aufgespielt und siehe da: es klappt. Ich kann nicht sagen, ob es daran liegt, dass ich owncloud als carddav server unter iOS6 schon hinzu gefügt hatte und das Update dann den falschen Eintrag beim Konfigurieren einfach übersprungen hat, oder ob die Änderungen, die ich bei owncloud wie her beschrieben:

    https://github.com/owncloud/contacts/issues/137#issuecomment-24444597

    angewandt habe dazu führten.

    Antworten

  5. Hallo,

    auch bei mir funktioniert seit dem Umstieg auf iOS 7 carddav nicht mehr. Wenn ich die von iOS 7 falsch eingestellte URL richtig stelle, kann ich zwar in iOS 7 einen Kontakte-Account ohne Fehlermeldungen anfügen, der Kontakte-Account wird jedoch im Programm Kontakte unter Gruppen nicht angezeigt.

    Ich bin völlig ratlos woran das liegen könnte, bzw. wie ich das Problem lösen kann.

    Hat hier jemand einen Tipp für mich?

    Danke!

    Antworten

  6. Hallo seeseekey,

    danke für die Antwort.

    Wenn ich den Bugreport mit meinen beschränkten Englisch-Kenntnissen richtig verstehe, gehen diese alle in die Richtung, die von ios7 verhackte URL zu berichtigen. Das habe ich schon vorgenommen. Ich erhalte von ios7 die Meldung, dass der owncloud-carddav-Account per ssl korrekt eingerichtet wurde (lauter Haken).

    Mein Problem ist aber, dass dier Account dann weder in den Kontakten noch im Einstellungsmenü z. B. als Standardaccount nicht auftaucht.

    Hierfür finde ich keinen workaround.

    Danke!

    Antworten

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>