Übernahme von Änderungen für den Fibaro Motion Sensor unter Homee funktioniert nicht

Für meine Heimautomation mittels Homee nutze ich unter anderem den Fibaro Motion Sensor in der Z-Wave-Variante. Dieser leuchtet, sobald eine Bewegung erkannt wird. Glücklicherweise kann diese Funktionalität unter Homee für das Gerät abgestellt werden. Allerdings kann es passieren, dass die Einstellung in Homee zwar geändert wurde, aber die Änderung beim Gerät nicht ankommt.

Der geöffnete Fibaro Motion Sensor

Hintergrund hierfür ist, dass die batteriebetriebenen Geräte einmal manuell aufgeweckt werden müssen, nachdem die Änderung vorgenommen wurde, damit diese zeitnah übernommen wird. Bei dem Fibaro Motion Sensor geschieht dies, nachdem er geöffnet wurde, über den verbauten Taster, welcher dreimal schnell hintereinander gedrückt werden muss. Anschließend leuchtet die LED des Sensors auf und die Einstellung sollte übernommen worden sein.

Firmware eines Zero 2-Controllers aktualisieren

Der Zero 2 ist ein Controller von 8BitDo, welcher über eine eigene Firmware verfügt. Dieses Firmware kann aktualisiert werden. Nachdem die entsprechende Firmware im Support-Bereich heruntergeladen wurde, sollte die heruntergeladene ZIP-Datei entpackt werden.

Der Zero 2 Controller im Vergleich mit den SNES-Controllern von 8BitDo

In dem Archiv befindet sich neben dem eigentlichen Firmware-Update ein Updater für Windows, sowie einer für macOS. Die Variante für macOS lässt sich allerdings im Moment nicht starteten, stattdessen erhält der Nutzer eine Fehlermeldung. Der Updater für Windows funktioniert hingegen ohne Probleme.

Die Update-Applikation unter Windows

Nachdem der Updater gestartet wurde muss der Controller mit einem kurzen Druck der Tastenkombination L + R + Start aktiviert werden. Die eingebaute LED fängt gelb an zu blinken. Sobald dies der Fall ist, kann der Controller an den Rechner angeschlossen werden. Im Updater kann nun der Button USB Update gedrückt werden. Nach der Auswahl des gewünschten Firmware-Updates wird der Controller, nach einer Bestätigung, aktualisiert und ist anschließend auf dem neusten Stand.

wAP ac wird in WinBox per LAN nicht gefunden

Bei dem Anschluss eines wAP ac von MikroTik, wunderte ich mich das dieser nicht über die in WinBox eingebaute Neighbors-Funktionalität gefunden wurde. Der Router war über die LAN-Schnittstelle an das Netzwerk angeschlossen. Bei der Standardkonfiguration des wAP ac als Access Point werden Pakete von der LAN-Schnittstelle allerdings gedroppt, sodass das entsprechende Auffinden des Routers nicht funktioniert.

Nach einem korrekten Reset befindet sich der Router im CAPs-Modus

In meiner Konfiguration sollte der Router als CAP konfiguriert werden, sodass der AP zentral über den CAPsMAN, den eingebauten WLAN-Controller der MikroTik-Router, verwaltet werden kann. Der Versuch die Einstellung über das Quick Set vorzunehmen scheiterte. Der Grund hierfür lag daran, dass der wAP ac für den Betrieb im CAPs-Modus zurückgesetzt werden muss.

So muss der Reset-Button gedrückt werden und das Gerät anschließend mit Strom versorgt werden. Nach fünf Sekunden fangen die LEDs an zu blicken und nach weiteren fünf Sekunden leuchtet sie wieder dauerhaft. An dieser Stelle muss der Reset-Button wieder losgelassen werden. Die Konfiguration des Routers wird zurückgesetzt und anschließend befindet sich der Router in der CAPs-Konfiguration und kann über die LAN-Schnittstelle konfiguriert werden.

Testprogramm für den ESP8266

Beim Setup, zur Nutzung des Mikrocontrollers ESP8266, wird ab und an ein Programm benötigt um die Funktionsweise des Controllers bzw. des Flashvorgangs zu testen. Der einfachste Weg dies zu testen ist es die integrierte LED des Controllers zu nutzen. Dazu wird folgendes Programm benötigt:

void setup() {
  pinMode(2, OUTPUT);
}

void loop() {
  digitalWrite(2, LOW);   
  delay(250);            
  digitalWrite(2, HIGH);  
  delay(250);
}

Das Programm definiert PIN 2 des Controllers als Ausgang und sendet anschließend alle 250 Millisekunden ein Signal an diesem PIN. Dies führt dazu, dass die eingebaute LED des Controllers in kurzen Abständen blinkt und somit das Setup und der Controller getestet werden kann.

LED bei der Nutzung der Raspberry Pi Kamera deaktivieren

Wenn man die Raspberry Pi Kamera nutzt, leuchtet während der Nutzung eine rote LED. Möchte man diese LED deaktivieren so muss die Datei /boot/config.txt bearbeitet werden:

nano /boot/config.txt

Dort muss der Parameter disable_camera_led hinzugefügt werden:

disable_camera_led=1

Anschließend muss der Raspberry Pi mittels:

reboot

neugestartet werden. Nach dem Neustart ist die LED bei Kameraoperationen abgeschaltet.